Welcome, Guest. Please Login
Interdesigner Software Development
  Visit Comparator Fast today Wink
  HomeHelpSearchLogin  
 
 
Network Clipboard Freezing (Read 4,641 times)
May 3rd, 2008 at 1:43pm

TexasTK   Offline
YaBB Newbies

Posts: 4
*
Quote Quote 
Network Clipboard freezes after a first use, i.e. I copy a file to a clipboard it will send the clipboard but then freeze and need to be manually shutdown from Task Manager.  I'm running Windows XP SP2 with all updates installed.  I've tried looking at the log but it gets wiped out.  I don't know where to go looking next.  Any thoughts?

Thanks,
TexasTK
 
IP Logged
 
Reply #1 - May 3rd, 2008 at 3:58pm

Daniel   Offline
YaBB Administrator

Gender: male
Posts: 185
*****
Quote Quote 
Hello,

Are you transferring files using Network Clipboard? Please ensure Network Clipboard is properly enabled on your firewall (if you use Windows Firewall, please follow the instructions at Help :: Tutorials :: Windows Firewall, or see online help at  http://www.interdesigner.com/Help/NetworkClipboard/index.htm

I suggest you to enable Debug Mode at log (right-click on log's view).

Which Network Clipboard is freezing? The Sender or the Receiver? Are you using the latest release?

How are you performing this task:

1) Using Auto-send feature
2) Manually send, from local to remote.
3) Remotelly get the clipboard from local computer.

Daniel  Cheesy
 
IP Logged
 
Reply #2 - May 12th, 2008 at 11:28pm

TexasTK   Offline
YaBB Newbies

Posts: 4
*
Quote Quote 
Daniel,

     You asked when does it freeze.  There are 2 times I've identified:

1)  When I select Options >> Administrative Tools
2)  When I Ctrl + C to capture text.  It will capture the text but then freeze.

I selected Debug mode for the log but nothing of note is recorded.

I have to go to Task Manager to force the program to end.  When I do, MS asks if I want to send information to them about the error.

What next?

Thanks,
TexasTK
 
IP Logged
 
Reply #3 - May 12th, 2008 at 11:58pm

Daniel   Offline
YaBB Administrator

Gender: male
Posts: 185
*****
Quote Quote 
Hello,

The behavior you describe is not normal. I'm unable to determine the problem. If NC (Network Clipboard) freezes just because using the Administrative Tools option, that's no reason for that. Maybe your installation becomes corrupted. I suggest you to reinstall NC, and make sure there is no other running program that is handling clipboard incorrectly. Outlook is a champion, but using default values help against this (a different annoying behavior, like firing a "clipboard change" notification or using clipboard to manage toolbar images).

You may disable other options that uses clipboard routines, like auto-save clipboard history (Options and Preferences :: Hot Keys / Automation, uncheck "Remember last 4 clipboards").

Also, ensure you have the latest release, and try to set defaults for Clipboard Monitor (Options and Preferences :: Advanced Settings :: Clipboard Monitor):
[x] Skip faster clipboards (skip time 20ms)
[  ] Beep when busy
[x] Disable own format
[  ] Auto-Ignore Invalid Format
[  ] Auto-Ignore 0-size formats
[x] Automatic Refresh
[x] Ignore Formats:
* Link Source
* Link Source Descriptor
* ObjectLink

(Please note since release 1.0.0.25, just need to click the "Set Defaults" button to get all this values, remember to click Apply button).

Hope this helps.

Regards,

Daniel  Cheesy
 
IP Logged